Collect API not working as expected
Incident Report for Price Edge
Postmortem

On May 4th at 4:21 PM CEST, we were alerted by a customer that there were issues with dashboards and product matching functionality in PriceEdge. After some initial investigation, we presumed the DW was the main cause because it was showing 99% CPU usage and an abnormal number of connections. As this was affecting several of our customer's possibility to fully utilize the solution the issue was raised as an incident and customers were informed via our status page at 17:03 CEST.

We then proceeded to fix the network connectivity of the DW machine but additional issues still remained in Dashboards and Item View. Further work was done, which meant disk space was increased on key machines followed by system restoring. At 21:53 CEST systems were back to normal.

We sincerely apologize for any issues this might have caused you as a user of PriceEdge and have taken several actions to improve our response time for future events as well as made improvements to our server setup.

Posted May 07, 2021 - 12:13 CEST

Resolved
All issues should now be fixed. Note that spiders collecting competitor data will still try to catch and won't run as normal until tomorrow.
Posted May 04, 2021 - 21:53 CEST
Monitoring
Dashboards are now back loading. We are monitoring the situation for other issues.
Posted May 04, 2021 - 21:22 CEST
Update
We are continuing to work on fixing the issue.
Posted May 04, 2021 - 20:29 CEST
Update
We are continuing to work on fixing the issue.
Posted May 04, 2021 - 18:08 CEST
Identified
We have identified that the issue is caused by our data warehouse. Work to restore it is still ongoing.
Posted May 04, 2021 - 17:27 CEST
Investigating
We are currently investigating this issue.
Posted May 04, 2021 - 17:03 CEST
This incident affected: APIs and Application.