Some API instances down
Incident Report for Price Edge
Postmortem

On the morning of April 16th, we suffered an incident due to API instances being stopped.

Upon investigation, we identified that the primary factor behind the incident was a memory leak issue encountered while handling very large datasets. Our engineering team responded by restarting the affected API instances, restoring accessibility to the impacted environments.

The total outage period for affected environments was 1 hour and 50 minutes.

Posted Apr 19, 2024 - 15:36 CEST

Resolved
On the morning of April 16th, we suffered an incident due to API instances being stopped. Upon investigation, we identified that the primary factor behind the incident was a memory leak issue encountered while handling very large datasets. Our engineering team responded by restarting the affected API instances, restoring accessibility to the impacted environments.

The total outage period for affected environments was 1 hour and 50 minutes.
Posted Apr 16, 2024 - 05:30 CEST