Some enviroments are reporting issues with showing items on rules
Incident Report for Price Edge
Postmortem

On December 3rd at 9:06 PM CEST, we were alerted by a customer that there were issues with our price rules assignment in PriceEdge. After an initial validation, we identified that this was a general issue and an incident was raised and communicated.

After debugging we identified that the root cause was a Hotfix deployed the previous day that caused the rule assignment table to be dropped (on save) and recreated without data due to a change of a data type.

In order to resolve it quickly, we triggered a re-publish of all the rules in all affected systems which finished at 14:00. No other action was needed since the re-triggering restored everything back to normal.

We sincerely apologize for any issues this might have caused you as a user of PriceEdge and have taken several actions to improve our testing procedures in order to catch issues like this automatically before reaching production environments.

Posted Dec 06, 2021 - 14:13 CET

Resolved
We're happy to inform you that we fixed the root cause of this issue. We apologize for the inconvenience.
Posted Dec 03, 2021 - 15:12 CET
Update
Until we have a fix in place we recommend all our customers to not change or resave any price rules until a hot fix is in place as that might cause this behavior.
Posted Dec 03, 2021 - 10:05 CET
Update
We are continuing to work on a fix for this issue.
Posted Dec 03, 2021 - 09:44 CET
Identified
Issue is related to rules scheduling
Posted Dec 03, 2021 - 09:39 CET
Update
We are continuing to investigate this issue.
Posted Dec 03, 2021 - 09:24 CET
Investigating
Hmmm. Something’s not quite right. We’re looking into a reported issue with our price rules item assignment. Sorry for the inconvenience, we will update you as soon as possible.
Posted Dec 03, 2021 - 09:23 CET
This incident affected: APIs and Application.