Server update
Incident Report for Price Edge
Postmortem

On April 25th we were informed about performance issues by several customers. After investigation, we concluded that the issues were related to due to a firewall overloaded by network traffic.

Upgrading the server hardware to fix this issue took longer than expected due to a corrupt image file, and the issue persisted after the upgrade. To address this, the backup process was changed to avoid a similar issue going forward.

We sincerely apologize for any issues this might have caused you and we have improved our internal processes to avoid this occurring again in the future.

Posted May 22, 2023 - 14:47 CEST

Resolved
This incident has been resolved.
Posted Apr 27, 2023 - 12:54 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 27, 2023 - 12:54 CEST
Update
Servers are now back up
Posted Apr 27, 2023 - 12:54 CEST
Monitoring
Hardware update is taking longer than expected and will prolong the downtime
Posted Apr 27, 2023 - 12:33 CEST
Identified
Downtime will start at approx 9:30 UTC (so 10:30 UK time, 11:30 CET time)
Posted Apr 27, 2023 - 10:54 CEST
Investigating
We are currently experiencing server issues and will do an update which will cause some downtime to rectify the issue.
Posted Apr 27, 2023 - 10:17 CEST
This incident affected: APIs and Application.