Server issues noticed
Incident Report for Price Edge
Resolved
All systems are now back to running as normal
Posted May 24, 2023 - 11:11 CEST
Investigating
We notice degraded performance for some of our clients to due server overload. We are working on a fix and things should be back to normal shortly
Posted May 24, 2023 - 10:44 CEST
This incident affected: APIs and Application.